Investigating Payment Issue with Collaborative AR

Incident Report for Versapay

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 11:15 EDT

Monitoring

We have validated that the fix has resolved the issue. We will continue to monitor the situation to ensure there are no lingering issues.
Posted Oct 03, 2025 - 11:02 EDT

Identified

We’re experiencing a potential issue with C-AR. We are seeing a small percentage of errors with payments made in Collaborative AR since last night. The team has rolled out a fix, and will continue to monitor to ensure payments are no longer seeing issues. We'll provide an update as soon as more information becomes available.
Posted Oct 03, 2025 - 10:44 EDT
This incident affected: Collaborative AR (formerly ARC) (Payment Services).