Versapay Autopay

Incident Report for Versapay

Monitoring

The auto pay jobs are currently being re-run. We expect all auto pay jobs to be complete shortly.
Posted Jun 10, 2026 - 17:52 EDT

Investigating

We are currently investigating reports of an issue impacting portions of the Versapay platform, specifically related to Autopay functionality. Our Engineering teams are actively working to identify the root cause and assess the scope of impact.

At this time, some users may experience intermittent disruptions or unexpected behaviour when processing payments.

We will continue to provide updates as more information becomes available. We appreciate your patience while we work to resolve this issue.
Posted Jun 10, 2026 - 11:26 EDT
This incident affects: Payments (Versapay Payment Gateway (TPro4)).