Investigating outage with CashApplication

Incident Report for Versapay

Update

We have deployed a fix to the login issues that some CashApplication users were experiencing. Users should now be able to log in and interact with the system as expected. Our teams are closely monitoring for recurrence.
Posted Apr 27, 2026 - 11:42 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2026 - 11:40 EDT

Identified

We’re experiencing a potential issue with CashApplication affecting a subset of clients. We'll provide an update as soon as more information becomes available.
Posted Apr 27, 2026 - 09:22 EDT
This incident affects: Cash Application (formerly DadePay) (Platform, Single Sign-On, Support Portal).