Investigating Payments Problems with Tpro3

Incident Report for Versapay

Resolved

We have successfully resolved the issue, and have validated that the solution is working correctly.
Posted Jul 14, 2025 - 11:41 EDT

Monitoring

We have identified the problem, and have implemented a temporary fix for expediency. Transactions are flowing again. We are in the process of completing the permanent fix.
Posted Jul 14, 2025 - 09:42 EDT

Investigating

We’re experiencing a potential issue with TPro3. We'll provide an update as soon as more information becomes available.
Posted Jul 14, 2025 - 09:15 EDT
This incident affected: Payments (TPro3 Payment Gateway).