BridgePay Service Issue with PAX Terminals
Incident Report for Versapay
Resolved
This incident has been resolved.
Posted Dec 26, 2023 - 16:44 EST
Monitoring
For our clients using PAX terminal devices, our partner BridgePay has reported an issue with their PayGuardian Cloud 3rd Party service. BridgePay has reported that the errors have stopped and they continue to monitor the issue.

For more information and real-time updates from BridgePay, please visit their status page: https://status.bridgepaynetwork.com/.
Posted Dec 26, 2023 - 15:22 EST
This incident affected: ERP Payments for NetSuite (Product).