Investigating mobile image upload Issue with Cash Application

Incident Report for Versapay

Resolved

The issue has been resolved.
Posted Jun 03, 2025 - 11:52 EDT

Update

An Update: this only impacts mobile image upload
Posted Jun 03, 2025 - 10:41 EDT

Identified

We’re experiencing an issue with Check Scanning on Cash Application. We'll provide an update as soon as more information becomes available.
Posted Jun 03, 2025 - 10:35 EDT
This incident affected: Cash Application (formerly DadePay) (Platform, Remote Capture).