The Payment Gateway is now stabilized, and system performance has returned to expected levels. Customers should begin to see improved response times and a reduction in timeouts.
Our team is continuing to monitor system health closely and applying measured tuning adjustments to ensure sustained stability.
Posted Jul 02, 2026 - 16:39 EDT
Investigating
Impact: TPRO4 Merchant Portal users
We are currently investigating a performance degradation in our Payment Gateway that was detected by our monitoring systems. TPRO4 Merchant Portal users may experience slower response times or intermittent payment failures during this period.
Our engineering and operations teams are actively working to identify the root cause and restore full performance.
What to do: If you are experiencing payment processing issues, please retry the transaction or contact our Care team for assistance.
Posted Jul 02, 2026 - 15:22 EDT
This incident affects: Payments (Versapay Payment Gateway (TPro4)).