Payment Gateway Processing Issues
Incident Report for Versapay
Resolved
Thank you for your patience. This issue has been resolved.

If you have any questions, please contact our Customer Care team at 866-999-8729, Monday- Friday, 8:00 am to 11:00 pm EST, or visit https://www.versapay.com/contact-us.
Posted Mar 26, 2024 - 14:18 EDT
Monitoring
Working with Fiserv fixes have been deployed fixes to address the payment processing issues some clients have been experiencing. Our teams are closely monitoring to ensure the issues have been remediated. We'll provide an update as soon as more information becomes available.
Posted Mar 19, 2024 - 11:28 EDT
Investigating
Our technical teams continue to work with Fiserv to resolve this issue. We apologize for the inconvenience this may cause.
Posted Mar 14, 2024 - 13:18 EDT
Identified
For our clients on the Fiserv Commerce Hub gateway, we are currently observing payment processing issues. As a result, you may be experiencing payment failures. We are actively working with Fiserv to remediate the issue.

We will continue to provide additional updates as soon as more information becomes available.

We apologize for any inconvenience this may cause.
Posted Mar 11, 2024 - 18:16 EDT
This incident affected: Payments (Third-Party Payment Gateways & Processors) and Collaborative AR (formerly ARC) (Payment Services).