PayPort EFT Funding Delay
Incident Report for Versapay
Resolved
The PayPort EFT Funding Delay issue has been resolved. Services should be operating as expected.

We apologize for any inconvenience this has caused. If you have any questions, please contact [email protected].
Posted Dec 15, 2023 - 12:36 EST
Monitoring
We have observed an issue with EFT files for our PayPort clients which may lead to a delay in funding. Our teams are closely monitoring and we expect a resolution later this evening. We'll provide an update as soon as more information becomes available.
Posted Dec 12, 2023 - 18:54 EST
This incident affected: Payments (PayPort).