Major platform service outage
Incident Report for Versapay
Monitoring
The issue that was affecting customers' transaction capabilities with our major payment processor platform has been resolved. We are continuing to monitor the situation to ensure everything remains stable. Please note that, as a result of the performance issue, you may experience delays in funding.

Thank you for your patience.
Posted Oct 17, 2024 - 12:57 EDT
Identified
We are aware of a reported outage on a major payment processor platform that is impacting some customers’ transaction capabilities. We are in contact with the platform and monitoring the situation closely. We will update as they give us information.
Posted Oct 17, 2024 - 09:41 EDT