CashApp performance Issues

Incident Report for Versapay

Resolved

We have been stable for over a week now. We will continue to focus efforts on performance and efficiency for Cash Application in an ongoing basis. We appreciate your patience during the incident last week.
Posted Oct 02, 2025 - 10:44 EDT

Update

Overall performance has stabilized. We will continue to monitor for outliers and edge cases that may still be impacted. Further adjustments will be made as needed to ensure consistent reliability.
Posted Sep 25, 2025 - 11:33 EDT

Update

Yesterday's changes led to noticeable improvements in response times. Overall performance has stabilized. We will continue to monitor for outliers and edge cases that may still be impacted. Further adjustments will be made as needed to ensure consistent reliability.
Posted Sep 24, 2025 - 08:53 EDT

Update

Recent changes have led to noticeable improvements in response times. Overall performance has stabilized. We will continue to monitor for outliers and edge cases that may still be impacted. Further adjustments will be made as needed to ensure consistent reliability.
Posted Sep 23, 2025 - 16:02 EDT

Update

We’ve implemented several changes aimed at improving response times. While early results show some improvement, system performance is still not where it needs to be. Our team is continuing to investigate and optimize. We continue to monitor closely and making further adjustments as needed.
Posted Sep 23, 2025 - 13:07 EDT

Monitoring

We have implemented some performance improvements that appear to have the impact we were hoping for. We will monitor overnight and into tomorrow to ensure everything is still working well.
Posted Sep 22, 2025 - 21:42 EDT

Update

We have resolved a number of performance issues, and performance is getting better. However, the team will continue to work around the clock to continue to improve things. We'll provide an update as soon as more information becomes available.
Posted Sep 22, 2025 - 18:21 EDT

Update

We are continuing to resolve the performance issues. We'll provide an update as soon as more information becomes available.
Posted Sep 22, 2025 - 11:47 EDT

Identified

We are experiencing some performance issues with Cash Application. We've determined the inefficient database activity which is impacting Cash Application. We're working to improve performance. We'll provide an update as soon as more information becomes available.
Posted Sep 22, 2025 - 08:25 EDT
This incident affected: Cash Application (formerly DadePay) (Support Portal).