TPRO3 Gateway Service Disruption

Incident Report for Versapay

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 14:42 EDT

Monitoring

The issue affecting the TPRO3 Gateway has been resolved, and card-present transactions are now processing normally. We will continue to monitor the system to ensure stability.
Thank you for your patience and understanding during this incident.
Posted Jun 18, 2025 - 13:28 EDT

Investigating

We are currently experiencing an issue with the TPRO3 Gateway, which is impacting the ability to process card-present transactions.
Our team is actively investigating and working to resolve the problem as quickly as possible.
We will share updates here as soon as more information becomes available. Thank you for your patience.
Posted Jun 18, 2025 - 12:00 EDT
This incident affected: Payments (TPro3 Payment Gateway).