Cash Application Slow Response
Incident Report for Versapay
Resolved
We have taken remedial action, and have not observed any recurrence of the issue.
Posted Dec 27, 2023 - 12:14 EST
Update
Our teams have taken remedial action to triage the issue. The issue continues to be investigated.
Posted Dec 22, 2023 - 11:16 EST
Investigating
We are receiving reports of slow responses and timeouts from users of CashApp. Our technical teams are actively investigating the issue. We'll provide an update as soon as more information becomes available.
Posted Dec 22, 2023 - 11:06 EST
This incident affected: Cash Application (formerly DadePay) (Platform).