Azure Outage impacting Cash Application

Incident Report for Versapay

Resolved

We have been monitoring the platform since the Azure outage was resolved, and no further problems remain.
Posted Oct 31, 2025 - 11:45 EDT

Monitoring

We have implemented a fix to bypass Azure, and Cash Application is working correctly again.

We will continue to monitor the situation to ensure there are no further issues.
Posted Oct 29, 2025 - 13:27 EDT

Investigating

We’re experiencing a potential issue with Cash Application due to an outage Microsoft Azure is experiencing. https://azure.status.microsoft/en-us/status

We'll provide an update as soon as more information becomes available.
Posted Oct 29, 2025 - 13:13 EDT
This incident affected: Cash Application (formerly DadePay) (Platform).