Resolved: Payment Processing Delays
Incident Report for Versapay
Resolved
We are aware of a recent issue affecting payment processing for some clients due to an outage with one of our payment partners, Fiserv. The issue has been resolved, and impacted transactions have been sent for settlement.

Impacted clients can expect to receive funding within 24 hours.

If you have any questions or require further assistance, please contact our Customer Care team.
Posted Jan 09, 2025 - 11:35 EST
This incident affected: Payments (Third-Party Payment Gateways & Processors).