Investigating Authorization Failures through our payment partner
Incident Report for Versapay
Resolved
This incident was resolved by our partner.
Posted Mar 02, 2024 - 09:44 EST
Investigating
We have been notified that a payment partner is currently experiencing a potential issue with payment authorization, which may impact our ability to authorize payments. We'll provide an update as soon as more information becomes available.
Posted Mar 01, 2024 - 20:14 EST