Google Cloud Service Disruption

Incident Report for Versapay

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 13:30 EDT

Monitoring

We are currently monitoring a widespread disruption affecting multiple Google services. Reports began around 2:00 PM PT, with users experiencing complete service outages across Google Cloud and related platforms. This may impact the performance of some product pages that rely on reCAPTCHA, Cloudflare, and Clover Gateway functionality.
Posted Jun 12, 2025 - 15:14 EDT