Duplicate Settlement Batch (TPro3 Payment Gateway)
Incident Report for Versapay
Resolved
Thank you for your patience. This issue has been resolved.

We have received confirmation from TSYS that the adjustments for interchange fee refunds have been entered and will be funded tomorrow, Saturday, 12/9.

If you have any questions, please contact our Customer Care team at 866-999-8729, Monday- Friday, 8:00 am to 11:00 pm EST, or visit https://www.versapay.com/contact-us.
Posted Dec 08, 2023 - 18:37 EST
Update
We continue to track towards a complete resolution of this issue by the end of the day, 12/8.

Nearly all of the transactions have been reversed.

Refunds for interchange refunds will be sent tomorrow, Friday, 12/8, and funded on Saturday, 12/9.
Posted Dec 07, 2023 - 17:18 EST
Update
We are prepping the interchange refunds.

We will provide another update tomorrow.
Posted Dec 06, 2023 - 17:12 EST
Update
The adjustments for rejected Visa and AMEX transactions have been completed.

TSYS will be making final adjustments to refund any interchange fees charged.

Our team is working towards a complete resolution of this issue by the end of the day, 12/8.

We will provide another update tomorrow.
Posted Dec 05, 2023 - 17:32 EST
Update
As outlined in our previous update, reversals for Mastercard, AMEX, and Discover transactions were completed on Friday, December 1st, and funded on Saturday, December 2nd.

Adjustments for rejected Visa and AMEX transactions were made today and you will notice one debit to your account. For these rejected transactions, cardholders (i.e., your customers) were not impacted.

There are some remaining transactions our team is still working to reverse.

We will provide another update by the end of the day tomorrow.
Posted Dec 04, 2023 - 18:38 EST
Update
Our technical team has developed a remediation plan to reverse this duplicate batch of transactions.

Based on the response from TSYS, here’s what you need to know.

1. Mastercard, AMEX, and Discover transactions will be reversed tomorrow, Friday, December 1st, and funded on Saturday, December 2nd.
-If the transaction was a sale, the cardholder will be credited.
-If the transaction was a refund, the cardholder will be debited.

2. Most of the Visa transactions were rejected so many of these cardholders were not impacted. As our merchant, you may notice a debit to your account for the adjustment.

We will continue to provide additional updates as soon as more information becomes available.
Posted Nov 30, 2023 - 18:18 EST
Update
Our technical teams are continuing to actively work with our partner, TSYS, to resolve this issue. We apologize for the inconvenience this may cause.
Posted Nov 30, 2023 - 13:47 EST
Update
Our technical teams continue to work with our partner to resolve this issue.
Posted Nov 29, 2023 - 09:52 EST
Identified
We have identified an issue in which a duplicate settlement batch from September 19th, 2023 was inadvertently sent to approximately 50 clients processing payments through TSYS.

We are in touch with TSYS to determine how best to reverse this duplicate batch of transactions. Please do not start to reverse the transactions on your own as it may cause more duplicates. We will provide an update as soon as more information becomes available.

We apologize for any inconvenience this may cause.
Posted Nov 28, 2023 - 14:00 EST
This incident affected: Payments (TPro3 Payment Gateway).