Authorization Issues with Fiserv Telecheck
Incident Report for Versapay
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 09:51 EST
Investigating
For our clients using Telecheck through Fiserv, we have been notified by Fiserv that they are experiencing authorization issues. Fiserv is investigating the issue and will provide updates as soon as they have more information.
Posted Mar 04, 2024 - 14:48 EST
This incident affected: Payments (Third-Party Payment Gateways & Processors).