Investigating an issue with images not loading in PDF Invoices created by Netsuite

Incident Report for Versapay

Monitoring

A fix has been implemented and detailed instructions were sent to NetSuite administrators. If you need further assistance, please contact Versapay support.
Posted Apr 04, 2025 - 08:46 EDT

Identified

We’re experiencing a potential issue with Images not loading in Invoices created by NetSuite. We'll provide an update as soon as more information becomes available. We have identified the issue and are working on a resolution.
Posted Apr 03, 2025 - 14:09 EDT
This incident affects: ERP Payments for NetSuite (Product).