TPro3 Payment Gateway Funding Delay
Incident Report for Versapay
Resolved
This incident has been resolved.

If you have any questions, please submit a Support Ticket by visiting our Support Contact Us page.
Posted Dec 26, 2023 - 10:21 EST
Investigating
Our platform encountered an issue when attempting to send the settlement batch to TSYS, which led to a delay in funding. We expect impacted clients to receive their funds tomorrow, December 22, 2023.

We apologize for any inconvenience this has caused. If you have any questions, please submit a Support Ticket by visiting our Support Contact Us page.
Posted Dec 21, 2023 - 15:45 EST
This incident affected: Payments (TPro3 Payment Gateway).